QCustomPlot Discussion and Comments

Compile errors when using MSVC2017 compilerReturn to overview

I am using the latest Qt and QCustomPlot versions.

I just added a library to my Qt project which requires the MSVC compiler (I was originally using MinGW). Unfortunately, this is creating compile errors related to my qcustomplot.h file. I've already spent a lot of time implementing QCustomPlot into this project and the new library that I'm adding is an absolute requirement, so any help or advice to circumvent this issue would be greatly appreciated!

QCustomPlot + msvc2017 works well for me.
What errors occur when you compile?

Here is a link to the list of errors: