QCustomPlot Discussion and Comments

Get error: iRangeDrag is not a member of QCPReturn to overview


i used qcustomplot to create a simple 2d plot to Display a curve. I activated iRangeDrag and iRangeZoom etc. and it worked just fine.

 ui->vxplot->setInteractions(QCP::iRangeDrag | QCP::iRangeZoom | QCP::iSelectPlottables | QCP::iMultiSelect); 

Now somebody else has been working on the sourcecode too and when i try to build the programm it gives me an error:

íRangeDrag is not a member of QCP

Also when i use autocomplete with QCP:: iRangeDrag and all the other i... are not shown!

What the heck has this guy been doing to my source code? I cant find any differences. When i exclude this line of code the Programm works!?

Any ideas would be appreciated


Download the newest version of QCustomPlot in the download section. Then all tampering of the miscreant will be nullified. Alternatively: Just talk to the guy?

I talked to him, he doesnt remember doing anything stupid!
Im also using the newest Version of QCP and tried using the original .h and .cpp files!

The Problem seems not to be the source code but the seetings of the project!