when I used vs2012+Qt5.2.0 Compilation the qcustomplot ,The following errors were reported:

1 >c ommonlqcustomplot. cpp (1659): error C2143: 语法错误:缺少“:”(在“{”的前面)
1 >Commoniqeustomplot. cpP (2301): error C2059: 语法错误:“{
1 >c ommoniqcustomplot. CPP (2301): error C2143: 语法错误:缺少“:”(在“{”的前面)
1 >c ommon'qcustomp1ot. cpP (2301): error C2143: 语法错误
缺少“”在“g”"的前面)
1 >Commoniqcustomplot. cpP (2320): error C2059: 语法错误:“{”
1 >c ommon'qcustomp1ot. CpP (2320): error C2143: 语法错误
缺少“:”(在“{"的前面)
1 >Commoniqcustomplot. cpP (2552): error C2059: 语法错误:“{”
1 > omm onqcustomplot. cpP (2552): error C2143: 语法错误: 缺少“:”(在“{”的前面)
1 >C ommonlgeus tomplot. cpP (2563): error C2059: 语法错误:“{”
1 >D omm onlqcustomplot. CPP (2563): error C2143: 语法错误: 缺少“:”(在“{”的前面)
1 >c ommon'qcustomp1ot. CpP (2564): error C2181: 没有匹配if的非法else
1 >Commoniqcustomplot. cpP (2565): error C2059: 语法错误:“{'
1 >D omm onlqcustomplot. CPP (2565): error C2143: 语法错误: 缺少“:”(在“{”的前面)
1 >C ommon'qeust omplot. epp (2565): error C2143:语法错误
(在“}
的前面)
1 >Commoniqcustomplot. cpP (2868): error C2059: 语法错误:“{”
1 >D omm onlqcustomplot. CPP (2868): error C2143: 语法错误: 缺少“:”(在“{”的前面)
1 >c ommon'qcustomp1ot. CpP (2868): error C2143: 语法错误
缺少“:”在“}”的前面)
1 >Commoniqcustomplot. cpP (2869): error C2181: 没有匹配if的非法else
1 >c ommon't qcust omplot. cpp (2870): error C2059: 语法错误
“{
1 >C ommonlgeus tomplot. cpP (2870): error C2143: 语法错误
缺少“:”(在“{”的前面)
1 >D omm onlqcustomplot. CPP (2870): error C2143: 语法错误: 缺少“:”(在“}”的前面)
1 >C ommon'qeustomplot. epp (2874): error C2059:语法错误
1 >Commoniqcustomplot. cpP (2874): error C2143: 语法错误:缺少“”(在“{”的前面)
1 >Commoniqcustomplot. cpP (3479): error C2059: 语法错误:“{”
1 >c ommon'qcustomp1ot. CpP (3479): error C2143: 语法错误
缺少“:”(在“{”的前面)
1 >D omm onlqcustomplot. CPP (3479): error C2143: 语法错误: 缺少“:”(在“}”的前面)
1 >Commoniqcustomplot. cpP (3498): error C2059: 语法错误:“
1 >c ommon'qcustomp1ot. CpP (3498): error C2143: 语法错误
缺少“”(在“{”的前面)
1 >Commoniqcustomplot. cpP (3498): error C2143: 语法错误:缺少“”(在“}”的前面)
1 >c ommon't qcust omplot. cpp (4029): error C2059: 语法错误
1 >c ommon'qcustomp1ot. CpP (4029): error C2143: 语法错误
缺少“:”(在“{”的前面)
1 >Commoniqcustomplot. cpP (4030): error C2143: 语法错误:缺少“”(在“}”的前面)
1 >C ommon'qeust omplot. epp (4054): error C2059:语法错误
1 >Commoniqcustomplot. cpP (4054): error C2143: 语法错误:缺少“”(在“{”的前面)
1 >Commoniqcustomplot. cpP (4055): error C2143: 语法错误:缺少“”(在“}”的前面)
1 >C ommon'qeust omplot. epp (4926): error C2059:语法错误:“[”
1 >Commoniqcustomplot. cpP (4926): error C2143: 语法错误:缺少“”(在“{”的前面)
1 >c ommon't qcust omplot. cpp (4942): error C2059: 语法错误:“{”
1 >c ommon'qcustomp1ot. cpp (4942): error C2143: 语法错误
缺少“:”(在“{"的前面)
1 >c ommon'qcustomp1ot. cpp (7857): error C2059: 语法错误:
1 >C ommon'qeustomplot. epp (785T): error C2059:语法错误
1 y ommori o2115+ 0mm1 nt rTT 17858.
eTYOT 02143: 语注错误
缺小“.”(在“{的前面1

Return reported many errors,I'm not sure what's wrong with my configuration. I haven't found the answer for a long time