QCustomPlot Discussion and Comments

For Visual Studio Add-in I don't have a .pro to add printsupportReturn to overview

I am using (just starting) to use the Qt Visual Studio Add-in as described here: http://www.bogotobogo.com/Qt/Qt5_Visual_Studio_Add_in.php but then I don't seem to have a Qt .pro file. I believe the Visual Studio project and solution files do that job. In the "Getting Started" QCustomPlot tutorial it says I need to add printsupport like this: QT += widgets printsupport. Without doing it I get 5 errors saying "Cannot open include file" 'QtPrintSupport": No such file or directory. How do I do that under Visual Studio? Thanks, Dave

If you say you're just starting, I'd recommend using QtCreator to develop software with Qt, as it's a much better experience than Visual Studio. I've had quite a few people complaining that Qt with VS in general doesn't work as smoothly as with QtCreator (Which is no surprise, given that QtCreator was specifically made for Qt).
That said, I don't use Visual Studio myself and just use it to test releases (to make sure they run with MSVC and don't cause warnings/errors that don't appear with GCC), and thus can't give support. Please contact Visual Studio support for how to set up a project. My best guess is that you have to add $(QTDIR)\msvc2010\include\QtPrintSupport to your project includes (In the C/C++ settings of your project)


@Dave Jervis, in VS: right click on Project name (in Solution Explorer), then QT Project Settings, then QT module and select Print Support


I am very grateful. Your solution was simple, functional and objective.
I did this and the error was gone. Thank you very much!

Thx anonym! The solution works pretty good! [MVS2015 + QT5.6.0+QCustomplot 1.3.2]

Thank you so much Anon, I searched a couple days for a solution and this is just gold!

OOO Thx you so much too!!!!)))) I

Thank you. It saved me.

Thank you so much Anon

Thank you, anonym!
I spent 3 days on seaching for graphics plotting library!!! YOU save my ASS!!!
Love U <3<3<3

it works ,save my ASS!!!

For Visual Studio 2019 users - Select Extensions->Qt VS Tools->Qt Project Settings->(Configuration Properties->Qt Project Settings)->General->Qt Modules

If you click on the Qt Modules row you should be able to use an arrow to "<Select Modules...>" and there you will find Print Support.

Thank you, Dave. I've been looking for this solution for more than an hour.